Xử lý sự cố Dial-on-Demand vấn đề định tuyến trong OSPF (phần 1)

Đăng ngày: . Bởi: . Lượt xem bài: 776

Phần này bàn về các vấn đề liên quan đến bộ nhớ DDR. Khi OSPF được cấu hình thông qua kết nối DDR, hãy chắc chắn để ngăn chặn Hellos OSPF vì OSPF gửi Hellos trên các liên kết point-to-point 10 giây một lần.

Các vấn đề phổ biến nhất liên quan đến OSPF trên các liên kết DDR như sau:
• Vấn đề: Hellos OSPF được đưa lên các kết nối
• Vấn đề: Hellos OSPF không nhận được qua kết nối
• Vấn đề: Demand circuit giữ các kết nối

1. Hellos OSPF được đưa lên các kết nối
Khi chạy OSPF cho mục đích sao lưu quay số trên các liên kết DDR, xác định một danh sách truy cập để xác định một cách rõ ràng interesting traffic. OSPF sử dụng một địa chỉ multicast 224.0.0.5 để gửi Hellos. Địa chỉ này phải bị từ chối trong danh sách truy cập để OSPF không đưa lên các liên kết 10 giây một lần.

Ví dụ:
R1#
interface BRI3/0
ip address 192.168.254.13 255.255.255.252
encapsulation ppp
dialer map ip 192.168.254.14 name R2 broadcast 57654
dialer-group 1
isdn switch-type basic – net3
ppp authentication chap
access-list 100 deny tcp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100

R1#show dialer
BRI1/1:1 – dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (2 secs)
Dialer state is data link layer up
Dial reason: ip (s=192.168.254.13, d=224.0.0.5)
Current call connected 00:00:08
Connected to 57654 (R2)

Chỉ ra rằng lý do cho sự liên kết sắp tới là Hellos multicast OSPF

Giải pháp:
Để giải quyết vấn đề này, từ chối Hellos OSPF trong interesting traffic. Trong cấu hình này, tất cả các traffic đến địa chỉ 224.0.0.5 bị từ chối. Điều này có nghĩa rằng Hellos OSPF hoặc cập nhật qua liên kết point-to-point này sẽ không đưa lên các liên kết sau khi thay đổi cấu hình này.

R1#
access-list 100 deny tcp any any
access-list 100 deny ip any 224.0.0.5
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100

Nó không phải là cần thiết để đưa 224.0.0.6 trong danh sách truy cập bởi vì chỉ có DR sử dụng địa chỉ này. Ngoài ra, vì không có DR trên các liên kết point-to-point, không có cần phải từ chối địa chỉ này trong danh sách truy cập.

2. Hellos OSPF không nhận được qua kết nối
Các tính năng mạch nhu cầu OSPF đã được giới thiệu trong phần mềm Cisco IOS phiên bản 11.2. Tính năng này tạo thành kề OSPF trên một liên kết và sau đó giữ cho lớp 2 để tiết kiệm chi phí điện thoại trong khi vẫn giữ kề OSPF qua liên kết này. Nếu liên kết tiếp tục trở lên, nó đánh bại mục đích của một mạch nhu cầu.
Các nguyên nhân phổ biến nhất có thể của vấn đề này như sau:
• Flap link tồn tại trong mạng.
• Các loại mạng được định nghĩa là broadcast.
• Một tuyến đường PPP nhận được phân phối vào các cơ sở dữ liệu OSPF.
• Một trong những thiết bị định tuyến không có khả năng sử dụng một Demand Circuit.

2.1. Flap link tồn tại trong mạng
Ví dụ:
R1#show dialer
BRI1/1:1 – dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (2 secs)
Dialer state is data link layer up
Dial reason: ip (s=192.168.254.13, d=224.0.0.5)
Current call connected 00:00:08
Connected to 57654 (R2)
R1# debug ip ospf monitor
OSPF: Schedule SPF in area 0.0.0.0
Change in LS ID 192.168.1.129, LSA type R,
OSPF: schedule SPF: spf_time 1620348064ms wait_interval 10s

Thấy rằng một sự thay đổi xảy ra trong cơ sở dữ liệu OSPF như là kết quả của một router LSA tái sinh bằng một router với một router ID của 192.168.1.129 vì flap link trong khu vực 0 .

Giải pháp:
Cấu hình trên R1 và R2:

router ospf 1
network 192.168.254.0 0.0.0.255 area 2
area 1 stub no-summary

Nguyễn Minh Hải – VnPro

Comments

comments

Xem thêm : 

Hãy like nếu bạn thích bài này

Mọi bình luận cho bài viết xin viết bằng tiếng Việt có dấu . Xin cảm ơn!

Gửi phản hồi

*