Ví dụ về cấu hình một mạng doanh nghiệp (tiếp theo): Etherchannel, port layer 3, OSPF, VoIP

Đăng ngày: . Bởi: . Lượt xem bài: 554

Mô hình mạng doanh nghiệp A kết nối với chi nhánh B.

Trụ sở chính gồm 4 phòng ban: Giám đốc, nhân sự, kinh doanh, kế toán.

Vlan 2 phòng Giám đốc             192.168.2.0/24      default-gateway: 192.168.2.252
Vlan 3 phòng Nhân sự               192.168.3.0/24      default-gateway: 192.168.3.252
Vlan 4 phòng Kế toán                192.168.4.0/24      default-gateway: 192.168.4.252
Vlan 5 phòng Kinh doanh         192.168.5.0/24      default-gateway: 192.168.5.252

Mô hình mạng doanh nghiệp

10. Cấu hình Etherchannel

SW1(config)#interface port-channel 1
SW1(config-if)#no switchport
SW1(config-if)#ip address 192.168.8.2 255.255.255.0
SW1(config)#interface range f0/1 – 2
SW1(config-if-range)#no switchport
SW1(config-if-range)#channel-group 1 mode on
SW2(config)#interface port-channel 2
SW2(config-if)#no switchport
SW2(config-if)#ip address 192.168.6.2 255.255.255.0
SW2(config)#interface range f0/1 – 2
SW2(config-if-range)#no switchport
SW2(config-if-range)#channel-group 2 mode on

Score(config)#interface port-channel 1
Score(config-if)#no switchport
Score(config-if)#ip address 192.168.8.1 255.255.255.0
Score(config)#interface range f0/3 – 4
Score(config-if-range)#no switchport
Score(config-if-range)#channel-group 1 mode on
Score(config)#interface port-channel 2
Score(config-if)#no switchport
Score(config-if)#ip address 192.168.6.1 255.255.255.0
Score(config)#interface range f0/5 – 6
Score(config-if-range)#no switchport
Score(config-if-range)#channel-group 2 mode on

SW1#show etherchannel summary

show etherchannel summary

Score#ping 192.168.6.2

ping 192.168.6.2

11. Đặt IP address cho các port layer 3

Score(config)#interface f0/2
Score(config-if)#no switchport
Score(config-if)#ip address 192.168.7.2 255.255.255.0

R1(config)#interface f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.7.1 255.255.255.0
R1(config)#interface s0/0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.1.1 255.255.255.0

R2(config)#interface f0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.9.2 255.255.255.0
R2(config)#interface s0/1/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.1.2 255.255.255.0

12. Cấu hình định tuyến OSPF
SW1(config)#router ospf 1
SW1(config-router)#network 192.168.8.0 0.0.0.255 area 1
SW1(config-router)#network 192.168.2.0 0.0.0.255 area 1
SW1(config-router)#network 192.168.3.0 0.0.0.255 area 1
SW1(config-router)#network 192.168.4.0 0.0.0.255 area 1
SW1(config-router)#network 192.168.5.0 0.0.0.255 area 1
SW1(config-router)#exit

SW2(config)#router ospf 1
SW2(config-router)#network 192.168.6.0 0.0.0.255 area 1
SW2(config-router)#network 192.168.2.0 0.0.0.255 area 1
SW2(config-router)#network 192.168.3.0 0.0.0.255 area 1
SW2(config-router)#network 192.168.4.0 0.0.0.255 area 1
SW2(config-router)#network 192.168.5.0 0.0.0.255 area 1
SW2(config-router)#exit

Score(config)#router ospf 1
Score(config-router)# network 192.168.6.0 0.0.0.255 area 1
Score(config-router)# network 192.168.7.0 0.0.0.255 area 1
Score(config-router)# network 192.168.8.0 0.0.0.255 area 1
Score(config-router)#exit

R1(config)#router ospf 1
R1(config-router)#network 192.168.7.0 0.0.0.255 area 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 1
R1(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 1
R2(config-router)#network 192.168.9.0 0.0.0.255 area 1
R2(config-router)#exit

SW1#show ip route

show ip route

SW1#ping 192.168.9.2

ping 192.168.9.2

SW2#ping 192.168.9.2

ping 192.168.9.2

13. Cấu hình VoIP

– Cấu hình Telephone Service
R1(config)#telephone-service
R1(config-te)#max-ephones 5
R1(config-te)#max-dn 10
R1(config-te)#keepalive 15
R1(config-te)#system message IPPhone
R1(config-te)#create cnf-files
R1(config-te)#ip source-addess 192.168.7.1 port 2000

R2(config)#telephone-service
R2(config-te)#max-ephones 5
R2(config-te)#max-dn 10
R2(config-te)#keepalive 15
R2(config-te)#system message IPPhone
R2(config-te)#create cnf-files
R2(config-te)#ip source-addess 192.168.9.2 port 2000

– Tạo Directory number
R1(config)#ephone-dn 1
R1(config-ep)#number 1111
R1(config-ep)#name hostIPPhone1
R1(config)#ephone-dn 2
R1(config-ep)#number 1112
R1(config-ep)#name hostIPPhone2

R2(config)#ephone-dn 1
R2(config-ep)#number 1113
R2(config-ep)#name hostIPPhone3
R2(config)#ephone-dn 2
R2(config-ep)#number 1114
R2(config-ep)#name hostIPPhone4

– Tạo Phone
R1(config)#ephone 1
R1(config-ep)#mac-add 56eF.E006.F80F
R1(config-ep)#type cipc
R1(config-ep)#button 1:1
R1(config)#ephone 2
R1(config-ep)#mac-add EF9F.E8F7.F7F7
R1(config-ep)#type cipc
R1(config-ep)#button 1:2
R1# debug ephone redister

R2(config)#ephone 1
R2(config-ep)#mac-add 6eF5.eF06.8E0F
R2(config-ep)#type cipc
R2(config-ep)#button 1:1
R2(config)#ephone 2
R2(config-ep)#mac-add F6F5.8EF7.F29E
R2(config-ep)#type cipc
R2(config-ep)#button 1:2
R2# debug ephone redister

Để thiết lập VoIP phải cài đặt bộ phần mềm Cisco IP Communicator trên 2 máy trạm và cấu hình tính năng CME dùng router như trên.

Dương Văn Thông – VnPro

Comments

comments

Xem thêm : 

Hãy like nếu bạn thích bài này

Mọi bình luận cho bài viết xin viết bằng tiếng Việt có dấu . Xin cảm ơn!

Gửi phản hồi

*