Mô hình thực nghiệm QoS (phần 2)

Đăng ngày: . Bởi: . Lượt xem bài: 751

– Cấu hình phân loại lưu lượng theo chiều vào trên R3
R3(config)#access-list 100 permit tcp any any eq 80 {ACL cho HTTP}
R3(config)#access-list 101 permit tcp any any eq 20 {ACL cho FTP}
R3(config)#access-list 101 permit tcp any any eq 21 {ACL cho FTP}
R3(config)#access-list 102 permit udp any any range 16384 32768 {ACL cho Voice}
R3(config)#class-map match-any http
R3(config-cmap)# match access-group 100
R3(config-cmap)#exit
R3(config)#class-map match-any ftp
R3(config-cmap)# match access-group 101
R3(config-cmap)#exit
R3(config)#class-map match-any voive
R3(config-cmap)# match access-group 102
R2(config-cmap)#exit
{Câu lệnh class-map: dùng để phân loại lưu lượng theo ý muốn của người sử dụng bằng cách đưa lưu lượng vào một class tương ứng (với tên class đặt tùy ý sao cho dễ gợi nhớ), có thể sử dụng kết hợp với nhiều công cụ phân loại như ACL hay dùng cơ chế NBAR … Lệnh class-map kết hợp với lệnh match để phân loại các gói tin vào trong các class đã tạo (tương ứng với ACL đã tạo).}

– Cấu hình đánh dấu gói tin đi vào (trên R3):
{Đánh dấu các gói tin trong mỗi lớp dịch vụ dùng lệnh set }
{Câu lệnh policy-map: dùng để quy định cách xử lý cho từng loại lưu lượng đã được phân loại, cách xử lý là xét độ ưu tiên cho các gói tin. Luôn tồn tại 1 loại cấu hình class-map tên là class-default nhằm phân loại tất cả các lưu lượng chưa được phân loại bởi những class-map trước.}
R3(config)#policy-map marking-in
R3(config-pmap)#class http
R3(config-pmap-cmap)#set ip dscp AF21
R3(config-pmap-cmap)#exit
R3(config-pmap)#class ftp
R3(config-pmap-cmap)#set ip dscp AF31
R3(config-pmap-cmap)#exit
R3(config-pmap)#class voice
R3(config-pmap-cmap)#set ip dscp EF
{Câu lệnh service-policy: Đây là câu lệnh dùng để áp dụng policy-map đã cấu hình lên một cổng tương ứng, mỗi cổng chỉ áp dụng được một policy-map theo hướng vào hoặc hướng ra.}
R3(config)#interface fastEthernet 1/0
R3(config-int)#service-policy intput marking-in

– Cấu hình đánh dấu gói tin đi ra (trên R3):
R3(config)# class-map match-any http
R3(config-cmap)# match ip dscp AF21
R3(config-cmap)#exit
R3(config)# class-map match-any ftp
R3(config-cmap)# match ip dscp AF31
R3(config-cmap)#exit
R3(config)# class-map match-any voice
R3(config-cmap)# match ip dscp EF
R3(config-cmap)#exit

– Cấu hình ưu tiên Bandwidth cho các class theo chiều ra:
R3(config)# policy-map queuing-out
R3(config-pmap)# class voice
R3(config-pmap-c)# priority 350
R3(config-pmap-c)#exit
R3(config-pmap)# class http
R3(config-pmap-cmap)# bandwidth 60
R3(config-pmap-cmap)# random-detect dscp-based
R3(config-pmap-cmap)#exit
R3(config-pmap)# class ftp
R3(config-pmap-cmap)# bandwidth 60
R3(config-pmap-cmap)# random-detect dscp-based
R3(config-pmap-cmap)#exit
R3(config-pmap)# class class-default {những lưu lượng còn lại}
R3(config-pmap-c)# fair-queue
R3(config-pmap-c)#exit
R3(config)#interface serial
R3(config-int)#service-policy output queuing-out

Kết quả đạt được
Dùng Netflow để đo các lưu lượng mạng. Thực hiện cuộc gọi bằng Polycom từ Client đến Server, đồng thời tải một lượng dữ liệu lớn dữ liệu từ FTP server. Nếu không áp dụng các kỹ thuật QoS thì lưu lượng FTP chiếm phần lớn Bandwidth. Kết quả được thể hiện trong hình sau:

Hình 4.3a Kết quả thực nghiệm khi chưa thực hiện QoS

Kết quả thực nghiệm khi chưa thực hiện QoS

Sau khi thực hiện cấu hình QoS như trên. Kết quả được thể hiện trong hình sau:

Hình 4.3b Kết quả thực nghiệm khi thực hiện QoS

Kết quả thực nghiệm khi thực hiện QoS

Chú ý: Lưu lượng UDP là của cuộc gọi H323, lưu lượng TCP là của FTP.

Nguyễn Ngọc Đại – VnPro

Mời các bạn xem phần 1 tại đây.

Comments

comments

Xem thêm : 

Hãy like nếu bạn thích bài này

Mọi bình luận cho bài viết xin viết bằng tiếng Việt có dấu . Xin cảm ơn!